We recommend using the latest version of Chrome for our platform, but the latest versions of Firefox, Safari, and Edge should also work. Lead Pilot does not support Internet Explorer, as it is no longer supported by Microsoft.

Did this answer your question?